You are here: Home » WordPress » Jakou verzi PHP bych měl používat pro WordPress?

Jakou verzi PHP bych měl používat pro WordPress?

Tato otázka se občas objeví v souvislosti s problémem rychlosti WordPress anebo kompatibility pluginů. Už minulý rok se začaly objevovat články, které slibují navýšení rychlosti WordPress o desítky procent, pokud začnete používat nejnovější PHP 7. Měření rychlosti však může být u WordPress poměrně zavádějící. Na sdíleném webhostingu záleží kolik toho zrovna fyzický server musí řešit, zdali neprobíhá nějaké zálohování apod. Na druhou stranu pokud vám váš poskytovatel hostingu nabízí PHP 7, proč toho nevyužít? Posoudit to můžete sami.

PHP 7 vyžaduje minimálně WordPress 4.3.1

Samotný WordPress podporuje PHP 7 od verze 4.3.1. Pokud tedy aktualizujete vždy na novou verzi neměli byste mít problém. Co však může zlobit jsou pluginy. Jestliže jsou starší nemusí fungovat vůbec anebo s chybami. Obdobně může nastat problém u šablon. Zvláště u těch, které jsou dělané na zakázku a není k nim poskytována aktualizace.

Přeštěte si   Máte zájem ovlivnit budoucnost WordPress?

Většina z pluginů i šablon, které se hodně používají, a dají se stáhnout na wordpress.org nemá s PHP 7 problém. Testuji je průběžně od vydání WordPress 4.4 a na nic jsem nenarazil.

Je třeba brát i v úvahu, že PHP 7 podporuje jen část webhostingů. Není prozatím samozřejmost. Někteří jsou stále zaseknutí u PHP 5.4, což není rozhodně ideální.

Starší verze PHP a WordPress

Naopak se staršími verzemi začíná být problém. Samotný WordPress je zpětné kompatibilní a minimálně do verze PHP 5.3 jsem u něj na nějaké komplikace nenarazil. Podle oficiálních stránek je současné minimum pro WordPress PHP 5.2.4. Ovšem doporučená je 5.6.

Ovšem u pluginů se začínají objevovat upozornění, že PHP 5.4 a dřívější verze jsou zastaralé a v lepším případě pro optimální chod daného pluginu nevhodné. V horším vyžadují nějaké dodatečné úpravy či nastavení. Takže pozor na to. S problémy jsem se setkal převážně u cachovacích pluginů.

Přeštěte si   Zranitelný plugin All in One SEO Pack

Dále je nutné si uvědomit, že PHP 5.4 je už nepodporovaná a od 3. září 2015 se u ní neopravují ani bezpečnostní chyby. Prostě už byste tuto verzi neměli používat. Novější 5.5 na tom není o moc lépe. Opravují se u ní jen bezpečnostní chyby ovšem jen do 10. května 2016. Pak podpora končí a budete podobně jako u 5.4 prostě odkázání na zabezpečení hostingu. Jestliže se objeví nějaká kritická díra, která se ve velkém zneužije, tak máte prostě problém.

V současné době tedy používejte PHP 5.6, která má podporu do 31. prosince 2018. Pokud jí váš poskytovatel webhostingu doposud nemá, je to na pováženou.

Share Button

Programuju v PHP už několik let spíše pro zábavu. Baví mě WordPress, protože tak lenivým lidem jako jsem já ušetří spoustu času. A rád sbírám reklamní flash disky. Tento blog používám pro utřídění myšlenek.

http://n-host.cz

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *