You are here: Home » Hosting » Nové verze WordPress jsou pomalejší na starším PHP

Nové verze WordPress jsou pomalejší na starším PHP

Většina z nás bere jako samozřejmost, že s každou novou verzí WordPress získáme nejen další novinky, ale také se zlepší výkon. Buď samotného WordPress anebo se zlepší podmínky pro vývojáře pluginů. Obdobně bereme jako samozřejmost, že s každou novou verzí PHP, na kterém WordPress jede, dojde také k nárůstu výkonu. Jenomže to nemusí být zcela tak pravda.

Jeff Starr na svém blogu perishablepress zjistil, že WordPress 4.4 se znatelně zpomalil na PHP 5.4. Říkáte si kdo dnes používá PHP verzi 5.4, která už není podporována vývojáři, a nevychází k ní ani bezpečnostní aktualizace? No řekněme, že existují webhostingové firmy, které přechod na vyšší verzi zatím ani nenabídli.

Přeštěte si   Shiny Updates ve WordPress 4.6?

Ovšem daleko více uživatelů na PHP 5.4 prozatím zůstává dobrovolně. Společnosti poskytující sdílený webhosting, totiž uživatele nenutí přejít na nové verze. Důvodem je, že spousta webů jede na starých skriptech a s novějšími verzemi PHP není kompatibilní. Předělat je by stálo hodně peněz, takže se s tím prostě netrápí. Respektive nechtějí to vůbec řešit. Za naprogramování zaplatili a jsou rádi, že to funguje. Pak je tu skupinka uživatelů, kteří jsou spokojeni a bojí se něco měnit. Vše zatím funguje jak má, jakákoliv úprava by mohla přinést zbytečné komplikace.

U WordPress toto ale řešit nemusíte, protože je na nejnovější verzi PHP připraven vždy s předstihem. Od WordPress 4.3.1 je připraven na PHP7. Pokud jsou pluginy a šablony kompatibilní s touto anebo novější verzí, tak neváhejte a přepněte si na webhostingu PHP na sedmičku.

Přeštěte si   Kde vydělat penízky na hosting a doménu

A co za to? Většina uživatelů uvádí, že zaznamenali nárůst rychlosti. Jejich domněnky potvrzují i srovnávací testy. Sami vývojáři PHP píší, že je 2x rychlejší než 5.6 a vyžaduje méně paměti. Takže jestli máte WordPress a u pluginů je uvedeno, že fungují s nejnovější verzí WordPress, tak neváhejte a přepněte si jí.

Naopak pokud musíte zůstat na starší verzi PHP 5.4 a horší, protože novější váš poskytovatel hostingu nenabízí, tak byste … no prostě měli jít jinam. PHP 5.5 je tu s námi od června 2013 a jestliže jí doteď nenasadil, tak zřejmě ani nenasadí. Vyberte si z velké nabídky konkurence na českém trhu a dopřejte WordPress co si zaslouží. Mimochodem spousta pluginů má problém se staršími verzemi PHP.

Share Button

Programuju v PHP už několik let spíše pro zábavu. Baví mě WordPress, protože tak lenivým lidem jako jsem já ušetří spoustu času. A rád sbírám reklamní flash disky. Tento blog používám pro utřídění myšlenek.

http://n-host.cz

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *