You are here: Home » WordPress » WordPress 4.8 ukončí podporu Internet Explorer 8, 9 a 10

WordPress 4.8 ukončí podporu Internet Explorer 8, 9 a 10

Matt Mullenweg řekl, že nadcházející verze WordPress 4.8 už nebude podporovat Internet Explorer 8, 9 a 10. K tomuto tématu probíhaly dlouhé diskuze mezi hlavními přispěvateli. WordPress se totiž vždy snažil zachovat zpětnou kompatibilitu poměrně dlouhou dobu. Důvodem tohoto razantního kroku je nový editor v nadcházející verzi.

Internet Explorer 8,9 a 10 je v podstatě mrtvou záležitostí. Sama společnost Microsoft v lednu 2016 ukončila podporu pro tyto verze a naplno se soustředila na jeho následovníka Edge. Ukončení podpory ze strany Microsoft ale hlavně znamená konec bezpečnostních aktualizací. Což může být do budoucna velký problém.

Mullenweg uvedl, že snaha pokračovat v podpoře těchto verzí IE brání ve vývoji WordPress (zvláště front endu).

Přeštěte si   Soubory šablon WordPress

„Uvědomuji si, že lidé, kteří stále používají tyto prohlížeče, je z nějakého důvodu nemohou nahradit, například jsou nainstalované v nějaké knihovně,“ řekl Mullenweg. „V závislosti na tom, jak počítáte jejich podíl, jsou tyto prohlížeče v součtu buď kolem 3% anebo pod 1% z celkového počtu uživatelů, v každém případě spadly už pod hranici, kdy je užitečné pokračovat v jejich podpoře.“

Ve snaze zjistit, kolik lidí tyto nezabezpečené a zastaralé prohlížeče stále používá, Jonathan Desrosiers shromáždil data ze tří různých zdrojů. Následující jsou čísla pro globální využití IE publikované společností StatCounter’s GlobalStats, které Desrosiers uvedl, jsou téměř identické s čísly WordPress.com.

  • IE8: 0,41%
  • IE9: 0,26%
  • IE10: 0,26%
  • IE11: 3,79%
Přeštěte si   WordPress 4.3

WordPress v těchto prohlížečích samozřejmě nepřestane fungovat, pouze už se nebude testovat bezchybnost od verze 4.8. Některé funkce v Administraci tak mohou být omezené. Zvláště se však bude jednat o ediotor. Mullenweg potvrdil, že další verze TinyMCE nebudou podporovat starší verze IE.

Rozhodnutí zrušit podporu pro IE 8, 9 a 10 se setkalo s u WordPress komunity vývojářů s nadšením. Zaměřit se na prohlížeče, které mají pravidelné bezpečnostní aktualizace, je lepší využití času a zdrojů pro jakákoliv Open Source projekt. Teoreticky to také může pomoct bezpečnosti. Pokud bude podmínkou pro užívání WordPress mít aktuální prohlížeč, mnoho lidí bude nuceno si nějaký pořídit. Ostatně na trhu jich je dostatek.

Jen pro zajímavost. Téma zvyšování minimálních požadavků na prohlížeče samozřejmě vedlo k tomu, že vývojáři živě diskutovali o ukončení podpory PHP 5.2. Tato verze je už bez podpory více než šest let. V březnu 2015 statistiky aplikace WordPress odhadly využití PHP 5.2 u 16,6% instalací. Dnes je to 5,1%. Hlavním argumentem proti ukončení podpory PHP 5.2 bylo, že je pro uživatele daleko snadnější začít používat nový aktualizovaný internetový prohlížeč než aktualizovat PHP na serveru. PHP 5.2 představuje miliony uživatelů, kteří by museli s novou aktualizací buď aktualizovat zastaralý software na serveru anebo se přestěhovat jinam.

Share Button

Programuju v PHP už několik let spíše pro zábavu. Baví mě WordPress, protože tak lenivým lidem jako jsem já ušetří spoustu času. A rád sbírám reklamní flash disky. Tento blog používám pro utřídění myšlenek.

http://n-host.cz

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *